Anyone have this happen!!!!!!!'m

Discussion in 'Long Range Scopes and Other Optics' started by KCherry, Aug 26, 2013.

  1. KCherry

    KCherry Member

    Messages:
    13
    Joined:
    Mar 23, 2013
    Win. Highwall in 7wsm. Burris Signature rings onLeupold bases. Everything was installed as religiously as I can. About 80 rounds before this happened. Rungs will need to be replaced. Could it be caused by Burris rings on the Leupold bases?
     

    Attached Files:

  2. MudRunner2005

    MudRunner2005 Well-Known Member

    Messages:
    11,872
    Joined:
    Oct 13, 2008
    I don't know what caused your situation...But everytime I've ever used Leupold bases, I've used Leupold rings.....To me that's not something you wanna mix & match with.

    Picatinny rail & ring brands don't matter, but as far as dovetail style, I don't think I'd mix and match those.

    But that's just me...
     
  3. bruce_ventura

    bruce_ventura Well-Known Member

    Messages:
    1,106
    Joined:
    May 22, 2011
    Is it just the windage screw that got damaged, or the base too?
     
  4. highridge1

    highridge1 Well-Known Member

    Messages:
    907
    Joined:
    Jan 24, 2008
    Best thing you can do is not use those windage adjustable bases. It is a very weak system. Go to a weaver/picatinny style with recoil lug.
     
  5. KCherry

    KCherry Member

    Messages:
    13
    Joined:
    Mar 23, 2013
    I am thinking of starting over with Weaver bases, and Burris Signature Zee rings. This should give me the strength of the weaver style base, cross bolt anchor in the ring, and still a little cant in the scope angle for longer ranges. Feedback would be greatly appreciated.
     
  6. markopolo50

    markopolo50 Well-Known Member

    Messages:
    63
    Joined:
    Jan 26, 2013
    Never had this happen and I have a couple of these set ups, but all Leupold. I prefer the dual dovetail mounts, nothing moving there. After all I never liked the ability to move the rear mount or the fact that something could go wrong.

    YMMV
     
  7. royinidaho

    royinidaho Well-Known Member

    Messages:
    8,901
    Joined:
    Jan 20, 2004
    I have used Redfield rings and bases and leupold bases and rings of that type for more than 3 decades w/o a problem....on things like '06 family of cartridges.

    Stuck with them when upgrading to 270AM and 338 Rum, both w/brakes.

    Almost immediately had failures similar to yours. Very bad juju!

    Went to double dove tail bases and solved all problem, so far.

    If you want complete confidence go with a rail and top cabin rings.