Scope sight in problem w/ NF ATACR 7-35x56mm


Well-Known Member
Apr 25, 2020
Recently upgraded my scope to NF ATACR 7-35x56 on a 20 MOA base 300wm. Tried to zero it shoots hi -13" @50yards.
I go to dial down and scope bottoms out!!! I follow instructions but zero stop will not allow further adjustment to lower POI .
Very frustrated after spending $$$. I have another NF on a different rifle and don't have any issues with it. Can anyone help?
Happy Independence Day ;)
I think it's the the zero stop . you want to remove the turret cap . loosen the 4 allen screws about 2 full turns . raise the upper zero stop clutch until it's about flush with the center brass bolt . snug the 4 allen screws . put the turret cap back on . sight the gun in . after you're sighted in , then turn the upper zero stop clutch down to make contact

could you have the rail on backwards ?
Thank you for your quick replies! The rail is on correctly. I will attempt to raise the zero clutch. When at range I tried to move clutch but couldn't figure out how to do it.. love NF but the instructions don't provide enough detailed information...just MHO. Probably the nut behind the trigger 😀
Could be the clutch is just tight? I just got a brand new NX8 that the clutch did not want to move after loosening the 4 screws. Ended up just being stuck. After breaking it loose, works fine. This is my 4th NF and the first time experiencing this.