Savage 110

Red Wulf

New Member
Joined
Jan 3, 2003
Messages
3
Hi my name is Tom Kudla (age 17) and I bought my first rifle (Savage 110 .270 WIN)about a month ago. I like to shoot at the range and shoot about 40 rounds a sitting. After a couple of shots my groups open up alot. It does not have the heavy barrel. Is this due to the heating up of the barrel? If so would adding a heavy barrel help at all? Thanks, Tom Kudla
 
G

Guest

Guest
Hi Red Wulf, Your problem could easily be either the lack of cleaning or the barrel heating.You will have to eliminate the variables through testing or the problem may make you crazy. Cleaning the gun every 15 rounds or so should eliminate the cleaning possibility. Any you can shoot a few groups letting the gun cool down between shots.Then compare the results to how the gun shoots when hot.I would try those things first then if you still have not identified the problem we can move on from there.But I'm guessing one of these factors or both of them combined is your problem.
 

Red Wulf

New Member
Joined
Jan 3, 2003
Messages
3
I made a mistake the rifle is the Savage 111 not the 110. I just cleaned it for the first time and have not yet shot it again. So the factor could have been the temperature? Tom

[ 01-03-2003: Message edited by: Red Wulf ]
 
Warning! This thread is more than 20 years ago old.
It's likely that no further discussion is required, in which case we recommend starting a new thread. If however you feel your response is required you can still do so.
Top