Sig Kilo 2400abs problem..."Profile not synced"

Discussion in 'Long Range Hunting & Shooting' started by Mossyhorn, Oct 11, 2019 at 4:22 PM.


Help Support Long Range Hunting by donating:


  1. Mossyhorn

    Mossyhorn Member

    Messages:
    14
    Joined:
    Apr 9, 2019
    I got a new kilo 2400 and I built my profile, followed all the instructions and I noticed that my drops are WAYYYY off from what they should be. Even tested it out shooting with it today. It called for 24 moa and it shot way high, time and time again. Adjusted myself and hit the target with 16.5moa adjustment.

    Came home and noticed in the HUD that when I range a target, it pops up on the phone with the moa drop. But it says Profile Not Synced. I hit the sync button and it just goes on saying "syncing" and it never syncs.

    Called Sig customer service and they asked for me to send screen shots of everything, but I haven't heard back yet.

    Has anyone else dealt with this?
     
  2. lewillia

    lewillia Member

    Messages:
    15
    Joined:
    Sep 11, 2019
    I just dealt with this last weekend. Make sure Bluetooth is on in the kilo, click on your Kilos serial number in the main screen on your phone and make sure it says connected. Go into your profiles and tell it to sync. I had to do this 3 times before it finally went.
     
  3. Mossyhorn

    Mossyhorn Member

    Messages:
    14
    Joined:
    Apr 9, 2019
    I ran thru and did everything from beginning to end. Deleted the app and tried again. Bluetooth is lit on the rangefinder screen when looking thru it. Cycled thru the mode and made sure it said on. Jumped on my phone, went to Bluetooth in the settings and it shows my rangefinder as being connected. I build a profile and select it and hit sync. And it doesn’t sync.

    I even went so far as to delete the app and set it up using my wife’s phone. Go through the same process and it does the same thing. I’m thinking there’s something wrong with the rangefinder itself, it’s sending to the phone, but it’s not receiving.
     
  4. PPR

    PPR Well-Known Member

    Messages:
    76
    Joined:
    Feb 9, 2012
    Just a thought, but make sure neither device is timing out in blue tooth. Happened to me several times before I got it figured out. Good luck. :D:D

    Paul
     
  5. Jeffrthehunter

    Jeffrthehunter Well-Known Member

    Messages:
    109
    Joined:
    Nov 27, 2016
    I have no problems with mine at this time but when I first installed the APP I had problems. Read somewhere to cycle power on the phone and bingo it worked. I have never had a problem since. As soon as I trigger my rangefinder the Sig app shows that I am connected, when the range finder goes dark (no display) then the app shows not connected ( I think this is normal).
    Hope this helps!