Geovid problems

Discussion in 'Long Range Scopes and Other Optics' started by wvcountryboy, Nov 21, 2011.

  1. wvcountryboy

    wvcountryboy Well-Known Member

    Dec 1, 2010
    My dad has a leica geovid. It is one of the older 7x42 "box" style ones. It has worked great since he bought it probablly 12 years ago. This past summer I was using it and the red square would come up then you'd try to take a reading and it would turn back off. I bought a new battery thinking that was the problem.

    Today, we tried to use it and you'd try to range something that was obviously 250 or farther then 300 then 400 and so on. it would read 39 almost all the time then sometimes it would say maybe 38 or maybe 41 but never more than 42 or less than 37 no matter what the real distance was. It seems like I can wiggle the battery and it works fine for a while then back to the same thing. I have the battery shimmed and it seems to be working ok for now.

    Has anyone had this problem or have a guess of what it could be?