Anyone else had issues with Swarovski range finder

Discussion in 'Long Range Hunting & Shooting' started by Marine sniper, Oct 28, 2008.

  1. Marine sniper

    Marine sniper Well-Known Member

    Messages:
    391
    Joined:
    Sep 11, 2005
    I have had two Swarovski range finders go TU in the last 6 months. They start out by giving slightly erratic readings, say 50 yards or so off, and then quickly progress to giving wildly different readings on the same target.....205....466....1789....126....all on the same target.

    I put fresh batteries in it both times and did not solve problem.

    John
     
  2. Eaglet

    Eaglet Well-Known Member

    Messages:
    2,779
    Joined:
    Feb 2, 2005
    btt btt
     

  3. Ernie

    Ernie <strong>SPONSOR</strong>

    Messages:
    2,841
    Joined:
    Jun 18, 2007
    Sounds like you have had bad luck.
    I have heard of a couple of people getting one or two bad ones, but it is not common-Give Swaro a call and tell them your frustrations and problems and then write a detailed letter when you send it in. Ask them to thouroughly check-out the one they send back to you whether it is a repaired one or a new one. I would also ask them if they have the heard of the problems you are having.
    That is what I would do anyway.
     
  4. Capt Academy

    Capt Academy Well-Known Member

    Messages:
    1,665
    Joined:
    Dec 31, 2006
    I have had mine for three plus years and it has worked fine. Never an issue with it.