SIG Kilo 2400 with Applied Ballistics!!

DocUSMCRetired

Well-Known Member
Joined
Nov 12, 2014
Messages
668
Location
Texas
So, the only negatives I see right now are a small issue with iOS (which is one reason I prefer Android) and issues with the tripod mount adapter.

Obviously the iOS issue is easily solved but I'm not understanding the adapter issue. Why isn't it fitted correctly?

I honestly don't understand why Sig couldn't manage to incorporate a integral tripod mount on the unit and not have to use an adapter?
It doesn't fit, or its a super tight fit? It is actually a VERY tight fit for all the units. I will send an email up asking them about it. No one has reported this issue to us through official channels. Not 1 person...
 

Andy Backus

Field Editor
Staff member
Joined
Dec 21, 2009
Messages
878
I wonder if the bracket shrinks more than the rangefinder in extremely cold weather causing problems? It was fairly cold when I tested the KILO 2400 over the holidays and mine fit fine.
 

DocUSMCRetired

Well-Known Member
Joined
Nov 12, 2014
Messages
668
Location
Texas
I wonder if the bracket shrinks more than the rangefinder in extremely cold weather causing problems? It was fairly cold when I tested the KILO 2400 over the holidays and mine fit fine.
That is a really good question. Unfortunately I am not in a position to test this, because it does not get really cold where I live.
 

Greyfox

Well-Known Member
Joined
Jan 21, 2008
Messages
5,542
Location
Northeast
That is a really good question. Unfortunately I am not in a position to test this, because it does not get really cold where I live.
I have used my adapter at both 70F and 30F. While snug, I felt no difference in attaching or detaching , getting the front edge of the 2400 to line up with the front edge of the adapter. My unit was received last week. Perhaps some adapters are out of spec? As an aside, I actually found that keeping the adapter on the unit aided steadiness when ranging off hand, or bracing the unit against an improvised support, window edge, elevation turret, etc.
 

dok7mm

Well-Known Member
Joined
Apr 13, 2015
Messages
1,729
Location
west texas
Because, it seems not many are having a problem with the tripod adapter, it is probably true that some are not within specs. Mine is not going to work at all. I don't see this as a big deal, I'll call Sig and I know they'll make it good.

I have worked diligently to make it work on my unit and it's a no go, regardless of temperature. I tried the one that Chad Dixon from LongRiflesInc made for my Kilo 2000 and it fit my 4000 perfectly, very snugly - but not too hard to attach or remove. So, I tried the new adapter on the 2000 and it fit perfectly. What's going on? The units appear to be identical, to my eye. Then it dawn's on me, the texture of the rubber grip on the 4000 is new and no oil from hands vs the well used 2000 w/ it's slightly worn texture with a little hand oil. I'm pretty sure it's not a problem, long term. I'm good to go.
 

dok7mm

Well-Known Member
Joined
Apr 13, 2015
Messages
1,729
Location
west texas
Because, it seems not many are having a problem with the tripod adapter, it is probably true that some are not within specs. Mine is not going to work at all. I don't see this as a big deal, I'll call Sig and I know they'll make it good.

I have worked diligently to make it work on my unit and it's a no go, regardless of temperature. I tried the one that Chad Dixon from LongRiflesInc made for my Kilo 2000 and it fit my 4000 perfectly, very snugly - but not too hard to attach or remove. So, I tried the new adapter on the 2000 and it fit perfectly. What's going on? The units appear to be identical, to my eye. Then it dawn's on me, the texture of the rubber grip on the 4000 is new and no oil from hands vs the well used 2000 w/ it's slightly worn texture with a little hand oil. I'm pretty sure it's not a problem, long term. I'm good to go.
 

HuntnPack

Well-Known Member
LRH Team Member
Joined
Feb 21, 2012
Messages
453
Location
The Wilderness
I also tried again to get the tripod mount to work on my Kilo.
It is a no-go. I contacted Sig and let them know of the issue I was having.
I could possibly force it on to the unit but probably not get it off.
It has already scuffed the side of the unit.
The person I contacted said they were not aware of the problem but would
Look in to it and get back to me.
I'm sure it's a small tight tolerance issue with the mount & will get resolved.
I'll use my bino mount for now instead, it works well.
 

berryreed

Well-Known Member
Joined
Dec 25, 2010
Messages
48
Location
Worland Wyoming
I wish I was having better luck with mine, I am about ready to send it back to Cabelas. Something is not right with it. It will not give me correct info for the bullet drop. It ranges fine but the hold is way off. I have taken screen shots of my phone and sent it to sig but have not heard back from them. Anyone else having this problem?
 

Attachments

Broz

Well-Known Member
Joined
Feb 3, 2007
Messages
8,638
Location
Townsend, Montana.
I wish I was having better luck with mine, I am about ready to send it back to Cabelas. Something is not right with it. It will not give me correct info for the bullet drop. It ranges fine but the hold is way off. I have taken screen shots of my phone and sent it to sig but have not heard back from them. Anyone else having this problem?
That pressure looks wrong? Do you have some locked on environmentals?
 

Reynolds02

Well-Known Member
Joined
Dec 10, 2008
Messages
158
Location
Meadville, Pa
Definitely see your density Altitude is way off! Just like Bro's said! The little things that are sometimes overlooked will hurt. Good luck with the 2400, mine is working fantastic so far! Seems like a good upgrade from the G7 so far. Just need to put them side by side in some tough environments next
 

berryreed

Well-Known Member
Joined
Dec 25, 2010
Messages
48
Location
Worland Wyoming
I am sure some of the readings are off because I am inside the house ranging out of my open window. It is 13 degrees here. Look at the rest of the data and compare it to LRBC charts it is near double what it should be. I even tried different bullets thinking that it might be that someone got the G1 and G7 numbers mixed up but the berger bullets were out as much as the SMK.
 

Trending threads

Top