Nightforce illuminated reticle trouble

J

Jritt

Member
Joined
Jan 17, 2010
Messages
6
Purchased new NF 5.5 x 22 x 56 and when it arrived the reticle wouldnt illuminate. I attempted to adjust the setting, but still no change. After installing a new battery the reticle lit up immediately--I assumed problem solved. The next day I mounted the scope and again pulled the knob to illuminate the reticle and it would not work. Has anyone had problems with the illum reticles in NF scopes? I plan to contact NF directly but curious if this is common. Thanks
 
B

Broz

Well-Known Member
Joined
Feb 3, 2007
Messages
8,636
Location
Townsend, Montana.
I have owned many NXS's and all worked well. Just a thought, but are you testing it in a dark or low light area? I can't see mine unless it is low light.

Jeff
 
B

B23

Well-Known Member
Joined
Oct 30, 2008
Messages
1,471
Location
Spokane, Wa.
I'm going to out myself as a dumb *** but I did exactly what Broz mentioned with my first NF. I'm not saying that's your problem but you may want to check it in low light.
 
B

Broz

Well-Known Member
Joined
Feb 3, 2007
Messages
8,636
Location
Townsend, Montana.
B23, you ain't the only one. Heck my first one I bought used and I didn't even know how to turn it on for quite a while...:D

Jeff
 
J

Jritt

Member
Joined
Jan 17, 2010
Messages
6
Yes I did think of that too and tried adjusting it in a very dark room and I couldn't get any illumination at any setting change of the set screw. I will contact NF and see what they think
 
B

B23

Well-Known Member
Joined
Oct 30, 2008
Messages
1,471
Location
Spokane, Wa.
I can't believe I'm going to admit this on an open forum but that was the first problem I had with my first NF. I thought what the heck I just spent all this money and the *** doesn't even work it won't turn on and I tried everything. Or so I thought.

Then I read the user manual. Amazing how well those instructions really do work when you use them. LOL
 
Buffalobob

Buffalobob

Well-Known Member
Joined
Jun 12, 2001
Messages
5,095
Location
Potomac River
23, you ain't the only one. Heck my first one I bought used and I didn't even know how to turn it on for quite a while

I thought the illuminated reticle was a special order option and when I sent a scope in for a zero stop I asked them to install an illuminated reticle also. :D I guess they thought it was pretty humorous.

I still have never used it for anything.
 
B

Broz

Well-Known Member
Joined
Feb 3, 2007
Messages
8,636
Location
Townsend, Montana.
I thought the illuminated reticle was a special order option and when I sent a scope in for a zero stop I asked them to install an illuminated reticle also. :D I guess they thought it was pretty humorous.

I still have never used it for anything.

Ha! sounds like a lot of us rip it out of the box and bolt it on, just like Christmas morning.. Ha ha.

You have to give NF credit here. They did an excellent job of making it look nice and in a handy place too. Not like other scopes with the big wart on the eyepiece.

Jritt, we kinda hi-jacked your thread, but it looks like you are correct in calling them. I bet they take good care of you. Please let us know what you find out.

Jeff
 
jmden

jmden

Well-Known Member
Joined
Nov 2, 2003
Messages
2,791
Location
Washington State
B23, you ain't the only one. Heck my first one I bought used and I didn't even know how to turn it on for quite a while...:D

Jeff


I didn't even know they came standard with ill. reticle until just before I ordered one. Good grief... Sometimes a guy should pay attention, huh? :rolleyes:
 
jmden

jmden

Well-Known Member
Joined
Nov 2, 2003
Messages
2,791
Location
Washington State
You have to give NF credit here. They did an excellent job of making it look nice and in a handy place too. Not like other scopes with the big wart on the eyepiece.


Jeff

Very true. A feature packed, very tough scope at a price that's very hard to beat.
 
M

MontanaRifleman

Well-Known Member
Joined
May 21, 2008
Messages
6,186
Location
South of Canada and North of Wyoming
I had a dead battery with mine when I first got it. Replaced it and it has worked fine ever since. I'm sure you didn't forget to turn it off and run the battery down or put the battery in backwards or anything like that :rolleyes:
 
J

Jritt

Member
Joined
Jan 17, 2010
Messages
6
The weird thing is I did replace the battery and it worked right away. But the next day it again wouldn't illuminate. I did double ck the battery direction and its correct. Makes me wonder if the light can short out or has a loose connection. Sent email to NF waitng for response
 

Similar threads

P
Replies
6
Views
3K
Stormrider
S
S
Replies
4
Views
3K
A
A
Replies
5
Views
2K
specweldtom
S
ml williford
Replies
2
Views
484
ml williford
ml williford
Top