Load or scope problem ?

Discussion in 'Rifles, Bullets, Barrels & Ballistics' started by Aussie, Feb 21, 2007.

  1. Aussie

    Aussie Well-Known Member

    Messages:
    250
    Joined:
    Apr 29, 2004
    I'm having problems with load development in my Sako .17 Rem. sporter . Rifle is pillar bedded and free floated .
    Currently on my 5th powder and now using 25 gn Berger HP . Seem to be able to get 4 out of 5 shots into a group of about 0.5 to 0.6 inches but throws a shot (usually right) about an inch but at the same height .
    Any ideas ? Mounts are OK .
    Scope is a new Bushnell Elite 4200 4 - 16 x 40 .
    Always seems to have been more horizontal dispersion of shots with this rifle than any other I have loaded for . I have only had it a few months and never tried another scope on it .
     
  2. Buffalobob

    Buffalobob Writers Guild

    Messages:
    5,085
    Joined:
    Jun 12, 2001
    Are you using CCI BR4 primers?
     

  3. Aussie

    Aussie Well-Known Member

    Messages:
    250
    Joined:
    Apr 29, 2004
    Bob ,
    No , Remington 7 1/2 .
     
  4. Guest

    Guest Guest

    Post deleted by Len Backus
     
  5. Aussie

    Aussie Well-Known Member

    Messages:
    250
    Joined:
    Apr 29, 2004
    Tried deeper seating (30 thou off the lands) this morning and was worse . Will try 15 thou into the lands this afternoon . Have tried others in between already .
    Scope next .
     
  6. 11bono

    11bono Member

    Messages:
    14
    Joined:
    Feb 22, 2007
    [ QUOTE ]
    Are you using CCI BR4 primers?

    [/ QUOTE ]Are they a bad primer?