Leupold Issues-tracking ??

Discussion in 'Long Range Scopes and Other Optics' started by dustybrown, Mar 2, 2010.

  1. dustybrown

    dustybrown Well-Known Member

    Messages:
    123
    Joined:
    Mar 25, 2009
    I have a VX 3 LR 4.5-14 30 mm tube 50mm obj. scope. 1/3 MOA ajustments..... and I was shooting today at 650 and 850 yards... all went well untill I reset to my zero... 200Yds. and shot a group and it was 6-7 inches low.... Have any of you guys had similar tracking isues with lepoulds ??? as I think about it this is the second time I have had this happen.... HELP!!! all mounts are good and tight...
     
  2. J E Custom

    J E Custom Well-Known Member

    Messages:
    7,309
    Joined:
    Jul 29, 2004
    No . It is not normal !

    If you zeroed your turrets and they don't return to the same POI then I would recomend
    sending it back to Leupold with an explanation of your problem and they will fix or replace
    your problem.

    J E CUSTOM
     

  3. dustybrown

    dustybrown Well-Known Member

    Messages:
    123
    Joined:
    Mar 25, 2009
    Ok , thank you.. Im trying to make sure i did not over look somthing obvious.. the turet cap set screws were tight. I am going to shoot again tomorrow and see if it happens again but even if it re zeros it seems to be a cofidence issue now. Thanks again....
     
  4. Catfish

    Catfish Well-Known Member

    Messages:
    167
    Joined:
    Jan 6, 2007
    I would call Leupold. I have never had that problem with a Leupold and I adjust my elevation everytime I change yardage.
     
  5. dustybrown

    dustybrown Well-Known Member

    Messages:
    123
    Joined:
    Mar 25, 2009
    I tried to recreate the issue today... five (5) shot groups with full revolutions in between and POI was very close each time retuning to my zero. So I must have either over rotated some how and not noticed.... Oh the joys of learning.... I did pound the heck out of my steel plate at 844 yards today... That made me feel better... Thanks again... And I hope I have seen the last of that issue my fualt or not...
     
  6. azsugarbear

    azsugarbear Well-Known Member

    Messages:
    1,150
    Joined:
    Sep 20, 2005
    I have had some tracking issues with a couple of my Leupolds. In my experience it is not normal, but it does occur. Keep an eye on it. If it happens again, then send it back to them for a once-over.