Carl Ziess scope issue.Help please.

Discussion in 'Long Range Scopes and Other Optics' started by C Gamboa, Mar 3, 2011.

  1. C Gamboa

    C Gamboa Member

    Messages:
    13
    Joined:
    Nov 15, 2010
    I have a 3.4X14-50 Conquest Ziess scope.on a .243 CZ (mod 550), it has being taken to the range just a few times.It was in hig rings and it funtioned ¨normaly¨; I decided to change the rings for a pair of lower profile,(both of them original CZ).
    When I tried to sight the scope,I noticed that the knob for widage (Right-left adjustment), turned only a limited number of clicks for left adjustment,but a lot to the right.Fortunately I cud Zero it at 200 meters with the last click,as a matter of fact ,I cud return 1 click,but that is all I have for left adjustment (1 click).
    The only issue I can think of,is that I probably tightened the rings too much ?.
    In my country for some ¨strange¨ laws,I can´t send it to the factory by mail,and we have no dealers.So I have to fix it by myself.
    Any input will be apreciated.
     

  2. bullfrog

    bullfrog Well-Known Member

    Messages:
    152
    Joined:
    Jul 27, 2010
    Doesn't sound like it's your scope. It's your rings being too far out of alignment with your barrel and action. You could try windage adjustable bases and rings from Leupold, Redfield, or Burris. Or better yet get signature zee rings from Burris with the offset insert kit so you can use weaver or picannty bases. The offset insert kit will allow you to get your scope centered or canted for long range. I try to use the signature rings whenever I can for their great grip and no scope ring marks.
     

  3. C Gamboa

    C Gamboa Member

    Messages:
    13
    Joined:
    Nov 15, 2010
    Thank you for your advise.It sounds like music for my ears. I checked last night,and Cz bases are not the best at all.I´l try to get those bases.
    Thanks again.