close
Long Range Hunting Online Magazine


Go Back   Long Range Hunting Online Magazine > Rifles, Reloading, Optics, Equipment > 7mm STW

Reply

Scope or base/ring problem?

LinkBack Thread Tools Display Modes
  #1  
Unread 12-29-2013, 07:49 PM
Silver Member
 
Join Date: Jul 2011
Location: Troy S.C.
Posts: 137
Scope or base/ring problem?

I am shooting a Remington 700 7mmSTW. It is a DRILL! Fingernail groups at 100 yards, 2 3/8" at 500 yards. Now for my new problem. I missed a deer at about 70yards so I came home and shot it. It was shooting 8" low 3" left, ok so maybe I bumped it in 2 months of hard hunting. Well, I re-zeroed it and went on hunting, a few weeks later I missed ANOTHER deer at about 80 yards! WHAT!! So I shot the rifle and dang, back 9"low and about 3" left,,,I re-zeroed the rifle and that's where I'm at now. My scope is a Bushnell 3x9x50mm DOA 650, bases are 2 piece Leupold and Leupold Rings...Now I cannot remember how long the bases/rings have been on this rifle,,many,many years (maybe 20 years +/-) when the rifle was a 7mmRemMag, could it be that the rings have gotten "slack" in them to allow this move, to the same place over time??? Any ideas will be helpful.
Thanks in advance guys "Sackett"
__________________

WAITIN FOR THE NEXT
Reply With Quote
  •   #2  
    Unread 12-29-2013, 08:53 PM
    Silver Member
     
    Join Date: Feb 2012
    Location: Washington
    Posts: 172
    Re: Scope or base/ring problem?

    Sackett

    Have you checked the trigger guard screws coming up into the action? These can come loose and cause problems too.

    Over time, the scope bases can come loose. It might be something to check and see where everything is at. On my Ruger #1 7mm STW, the recoil moved the factory Ruger rear ring in the factory cuts. I had to use a different ring so that they would hold better.

    Hope some of this helps.

    Bill
    Reply With Quote

      #3  
    Unread 01-01-2014, 05:09 PM
    Platinum Member
     
    Join Date: May 2012
    Posts: 4,139
    Re: Scope or base/ring problem?

    Check all your screws (including scope attachments) and re-loc tite where needed... also put a known good scope on to see if you fried your scope if the screws are good. Also check to see if you are crimping the rings into the scope as that'll cant the erector assembly and she'll hop around bad.
    Reply With Quote
      #4  
    Unread 01-13-2014, 12:23 PM
    Silver Member
     
    Join Date: Jul 2011
    Location: Troy S.C.
    Posts: 137
    Re: Scope or base/ring problem?

    Apparently it was a base/ring problem? I replaced the old leupold bases/rings with new leupold STD 2 piece bases and leupold rings. It is back shooting one hole groups at 100 yds.
    __________________

    WAITIN FOR THE NEXT

    Last edited by Sackett; 01-13-2014 at 12:24 PM. Reason: spelling
    Reply With Quote
    Reply

    Bookmarks

    Thread Tools
    Display Modes



    All times are GMT -5. The time now is 06:32 PM.


    Powered by vBulletin ©2000 - 2017, Jelsoft Enterprises Ltd.
    Content Management Powered by vBadvanced CMPS
    All content ©2010-2015 Long Range Hunting, LLC