Long Range Hunting Online Magazine


Go Back   Long Range Hunting Online Magazine > Hunting > PSE TAC 15/15i Crossbow Hunting Forum


Reply

Tac 15i cranking issues and bolt turning out

 
LinkBack Thread Tools Display Modes
  #8  
Old 09-17-2012, 04:12 AM
Junior Member
 
Join Date: Sep 2012
Posts: 1
Re: Tac 15i cranking issues and bolt turning out

I've had the same thing happen to me while sighting in the tac.. after about the 3 time it backed out i used an old trick of putting finger nail Polish on the threads and put it back to gather no problems so far only time will tell....
Reply With Quote
  #9  
Old 09-17-2012, 01:15 PM
Bronze Member
 
Join Date: May 2001
Location: Arco, ID. USA
Posts: 51
Re: Tac 15i cranking issues and bolt turning out

Quote:
Originally Posted by kcpredator View Post
I've had the same thing happen to me while sighting in the tac.. after about the 3 time it backed out i used an old trick of putting finger nail Polish on the threads and put it back to gather no problems so far only time will tell....
Yeah same happened to me. I saw the bolt before it was completely out and would cause a problem. I then, used a small amount of blue loctite. That was the first year I owned the bow and it's held for 2+ more years since with no problem. If you use loctite it's always the blue, never the red unless you want it permanent.
Reply With Quote
  #10  
Old 09-18-2012, 09:23 AM
Junior Member
 
Join Date: Aug 2012
Location: PA
Posts: 12
Re: Tac 15i cranking issues and bolt turning out

Thanks for the feed back. I am Still waiting on my tac from PSE!!!! I WAS TOLD 4 weeks, its now 5 weeks and the NEPA Pro shop is giving me a run around. I called PSE and they tolld me I needed a RA #. Called Shop for the # and owner refused to give it to me. He stated it would be like giving out his personal ID out. I never heard of such a thing,something smells like fish to me. I called last week and spoke to one of the techs at the newly opened pro shop.and he stated it was just sent back a couple of weeks ago!!!!. If this is the case, for a newly opened shop, thay will not last long! I have shot a total of 12 arrows out of this thing. I spent over 625.00 dollars on upgrades that have been collecting dust for over a month now. Opening day is in a couple of weeks and I can not even use my bow due to a hand injury. I,m totally disgusted with the hole dealing. Sorry for bleeding out my problems,but come on!
Reply With Quote
  #11  
Old 09-19-2012, 06:16 PM
Junior Member
 
Join Date: Aug 2012
Location: PA
Posts: 12
Re: Tac 15i cranking issues and bolt turning out

Update!!! I CALLED PRO SHOP AND ASKED ABOUT MY UNIT. OWNER SAID COME DOWN AND PICK IT UP........? It came in yesterday, lucky I CALLED I GUESS:-) I picked it up and it was handed to me in its case like a hot potato, I removed it and notice that the dowel rod was bent in the block that the rope is attached to. I showed owner and he felt instead of sending it back for another 5 weeks, he would streighten it with a pair of pliers. It came out ok, so back home it went. I took it out when I hit the house and saw that the main reason why it was sent back was NEVER REPAIRED BY PSE!!!!! I lost it. I called pro shop and asked if he looked at it when it came back? HE SAID NO, IT SHOULD HAVE BEEN FIXED he A S S U M E D. The bearing housing that broke was never repaired, bearings are exposed. He called rep and a new bearing is on it way.......? Please advise........... CALL PSE ?????

Last edited by Bowgadget; 09-19-2012 at 09:16 PM. Reason: adding
Reply With Quote
  #12  
Old 09-20-2012, 01:18 PM
Bronze Member
 
Join Date: May 2001
Location: Arco, ID. USA
Posts: 51
Re: Tac 15i cranking issues and bolt turning out

Sorry to hear that, and I woulda lost it too!

To clarify: The thing I described above was my 2ed go round with this same problem. The first time it was exactly the same as yours. I didn't know yours was actually damaged. First time: I had trouble cranking, noticed the bolt had backed out, found the cracked housing, etc. I bought one of the first bows sold to the public way back, and thru a dealer off the internet in Maine. When this happened I immediately called PSE. They said send it to the dealer. I said no way, because I live in Idaho & don't know them from "Adam". Then he asked for the sales receipt and such which I immediately provided. He had me remove the part as an assembly and ship to him. He also gave me a PO authorization, claim # or whatever it was, and said to address to him personally and he'd ship back to me the same method as I sent it. I had stressed to him that time was critical here. I sent UPS 2ed Day with tracking. Of course after confirming their receipt, and giving them about 5 days and hearing nothing, I called and ask for the Tech by name. He had already shipped it back.

Overall I had a great experience working thru that single person and he gave me great service. All in all I think the bow was out of service 10 days, maybe 12, can't remember exactly. Since then I had always kept an eye on that area. I also made a habit of putting a wrench on it rechecking torque. Then one day it backed out but I caught it before any damage was done. Right then and there is where the blue loctite came in.

If any way possible I'll ALWAYS go direct to PSE. They don't seem to like it & want you to support their dealer, but IMO with your bad experience no one can blame you for NOT. I'd say screw the dealer because he sounds like a real tool! Those bolts turn as the carriage moves which can/will cause them to lose torque. Anyway, that's my saga and can confirm that area needs extra attention by the user because bad things happen when the bolts loosen (**** breaks).

What's the latest on your bow?
Reply With Quote
  #13  
Old 09-20-2012, 06:32 PM
Junior Member
 
Join Date: Aug 2012
Location: PA
Posts: 12
Re: Tac 15i cranking issues and bolt turning out

Thanks again for the info. on your unit. I'm at a stand still, I dont no if the tac is safe to shoot. No help from the TOOL (LOL). I took advanged of the down time and installed eveything except the timney trigger. I shot it to paper tune the Ultra rest SThdX. dead center left and right, nock low, lowered it and a shot bullets after the move. I checked that bolt before shooting and it was tight. Shot 3 bolts and it was loose! I had some Loctite 242 on hand and so far so good. Im still leary on the hole top half of that bearing missing! Before Slamming PSE anymore I'll call tommarow to see if it was even sent back.
Reply With Quote
  #14  
Old 09-26-2012, 12:42 PM
Junior Member
 
Join Date: Aug 2012
Location: PA
Posts: 12
Re: Tac 15i cranking issues and bolt turning out

Update on tac, I attached all the goodies, need to shim front sight to hit at 20 yrds and hit it dead on first shot. I was working my way back to 60 yrds for the optimizer zeroing and while cranking back I heard the dreaded crack of a limb..... I got in my truck and ran over this thing until it was flat!!!!!!!!!!!! (just kidding) Called PSE and tech was aware of the bearing not being repair after 5 weeks and the limb took the cake on this unit. Sent it back and it will be around 2 weeks for a brand new one. I think I'll burn some sage weed around the new one to remove any bad spirits..... bowgadget
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes


Similar Threads for: Tac 15i cranking issues and bolt turning out
Thread Thread Starter Forum Replies Last Post
BC issues BB28MX Rifles, Bullets, Barrels and Ballistics 16 06-18-2012 09:08 PM
tac 15 i cranking question J calvin PSE TAC 15/15i Crossbow Hunting Forum 0 10-12-2011 11:49 AM
Cranking Tac-15I longtines PSE TAC 15/15i Crossbow Hunting Forum 1 03-20-2011 07:57 PM
TAC 15 Issues jbmm411 PSE TAC 15/15i Crossbow Hunting Forum 7 12-08-2010 03:13 PM
having issues foreign Bowhunting 1 01-06-2010 10:32 PM


All times are GMT -5. The time now is 10:44 AM.


Powered by vBulletin ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Management Powered by vBadvanced CMPS
All content ©2010-2014 Long Range Hunting, LLC