Long Range Hunting Online Magazine


Go Back   Long Range Hunting Online Magazine > Hunting > PSE TAC 15/15i Crossbow Hunting Forum


Reply

TAC 15 Issues

 
LinkBack Thread Tools Display Modes
  #1  
Old 11-09-2010, 09:26 PM
Junior Member
 
Join Date: Nov 2010
Posts: 12
TAC 15 Issues

I know Im way behind on these threads but I've owned the TAC 15 since PSE's first offering (was on the waiting list). Got the xbow and liked a lot of the features but here are some things that are a little frustrating. Let me know if you all have a work around or have experienced the same issues:

1. Scope line of sight - I can see part (almost half) the whisker biscuit in the line of sight of the scope. I installed an extra high set of rings which helps but these rings wont work with the HHA Optimizer.
2. If I use medium height rings with the HHA Optimizer...when at full eleveation...all I see is the whisker biscuit. I have not shot the xbow using the optimizer so I don't know if I have to go to full elevation with it or not. Any info on how to set up the Optimizer and or what scope/rings to use to get around this problem?
3. The string is cutting into the rubber string "dampeners or stoppers" and causing them to split. I called PSE and they said to loosen the set screw (?) and back the stoppers off the string the thickness of a credit card. I do not have a set screw and no way to back the stoppers off the string. I'll have to call them back...the tech must be smoking something. I ordered new stoppers but fear they will just wear out like the last ones. Anyone experience this or can tell me if their string rests against the stopper in the uncocked position?
4. I have started to fletch my own shafts because the factory fletching gets peeled back in short order...Im leaning toward Flex Fletch low profiles. Anyone have any info on what fletching/glue is working for them?

Any info would be appreciated...thx, jb
Reply With Quote
  #2  
Old 11-09-2010, 09:42 PM
PUBLISHER
 
Join Date: May 2001
Posts: 5,964
Re: TAC 15 Issues

1. I see a small part of the biscuit in the bottom of the view, not bothersome. This is at the lowest power.

3. I have over 400 shots through mine with no splits. But I don't see any set screw either.

4. I have fletching issues, too. It seems if the front edge of the vanes are going to lift, it will happen within the first few shots of each new arrow. If I notice this happening, I trim the leading edge of the vane with a tiny scissors and then put a dab of glue at the leading edge.
__________________


Long Range Rifles, LLC - Ready To Ship

Components and assembly by LRH Sponsors

Last edited by Len Backus; 11-09-2010 at 09:45 PM.
Reply With Quote
  #3  
Old 11-09-2010, 10:03 PM
Junior Member
 
Join Date: Nov 2010
Posts: 12
Re: TAC 15 Issues

Thx for the info. I'm gonna follow up with PSE on the string bumper problem. I have not shot anywhere near 400 shots and my bumpers are really damaged. Does your string rest on the bumpers when the bow is not cocked? I'll try your method with the Fletching. I just started getting into Fletching so now I have the glue etc. Thx for the info. Jb
Reply With Quote
  #4  
Old 11-13-2010, 08:03 AM
Platinum Member
 
Join Date: Jul 2004
Location: Texas
Posts: 5,631
Re: TAC 15 Issues

I solved the fletching issue by using real feathers And tapering the front of the Fletch
and applying a dab of fletching cement.

I you use vanes , Take some Lacquer thinner and wipe the base of the vane to remove
any oils or powder just before fletching and it will have to be cut off to be replaced.

J E CUSTOM
__________________
"PRESS ON"
Reply With Quote
  #5  
Old 11-13-2010, 11:18 PM
Silver Member
 
Join Date: Aug 2010
Posts: 154
Re: TAC 15 Issues

Quote:
Originally Posted by jbmm411 View Post
Let me know if you all have a work around or have experienced the same issues:

4. I have started to fletch my own shafts because the factory fletching gets peeled back in short order...Im leaning toward Flex Fletch low profiles. Anyone have any info on what fletching/glue is working for them?
I can tell you that I have had trouble with PSE's TAC 15 arrow fletching coming loose in multiple ways. Some start to come loose at the front, some come loose in the middle and some just come completely off. From inspections of a few arrows' fletchings it appears the glue is not sticking to the shafts. The bad part of this is PSE is paying little or no attention to the matter.

I have read elsewhere where others are seeing similar fletching issues. A few people are just stripping all there TAC 15 arrows and refletching them. On the topic of refletching, I have read where a couple of people have had success using just two quick-spin like vanes vs. the original four Duravanes.
Reply With Quote
  #6  
Old 11-16-2010, 10:27 PM
Junior Member
 
Join Date: Nov 2010
Posts: 12
Re: TAC 15 Issues

Thanks for the info. I agree that the quality of the tac15 fletching/glue is lacking. I am refletching and experimenting with different glue/fletching options. I am going to try an arrow wrap with both the duraflex fletching same size as the standard tac15 arrow but in bright green and I will also try the wraps with flex fletch low profile 400s. If they work out Ill post some feed back.

Thx,
J
Reply With Quote
  #7  
Old 12-08-2010, 02:52 PM
Junior Member
 
Join Date: Dec 2010
Location: western Maryland
Posts: 13
Re: TAC 15 Issues

Quote:
Originally Posted by jbmm411 View Post
I know Im way behind on these threads but I've owned the TAC 15 since PSE's first offering (was on the waiting list). Got the xbow and liked a lot of the features but here are some things that are a little frustrating. Let me know if you all have a work around or have experienced the same issues:

3. The string is cutting into the rubber string "dampeners or stoppers" and causing them to split. I called PSE and they said to loosen the set screw (?) and back the stoppers off the string the thickness of a credit card. I do not have a set screw and no way to back the stoppers off the string. I'll have to call them back...the tech must be smoking something. I ordered new stoppers but fear they will just wear out like the last ones. Anyone experience this or can tell me if their string rests against the stopper in the uncocked position?

Any info would be appreciated...thx, jb
I don't own one "yet" but looking at the design..... can't you simply unscrew the damper from the riser, remover the rubber bumper, cut about an 1/8" from the tube, replace the rubber bumper and reinstall it to the riser? Seems like an easy fix but I'm just speculating since I've not had one in my hands personally.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes


Similar Threads for: TAC 15 Issues
Thread Thread Starter Forum Replies Last Post
DPMS 260 issues? Broz Equipment Discussions 33 10-29-2010 09:57 AM
Accuracy Issues Huvik Long Range Hunting & Shooting 5 09-14-2010 05:48 PM
having issues foreign Bowhunting 1 01-06-2010 10:32 PM
22-250 issues- help? peppy1hunting Reloading 2 11-28-2008 09:35 AM
Scope Issues!!! ktmhk53 Long Range Scopes and Other Optics 3 03-22-2003 07:52 PM


All times are GMT -5. The time now is 10:24 AM.


Powered by vBulletin ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Management Powered by vBadvanced CMPS
All content ©2010-2014 Long Range Hunting, LLC